4x Half Bridge load cells

By | March 10, 2022

This article shows the wiring of cheaper “half bridge load cells” (YZC-161E). Such half bridge weight sensors are available on Ebay partly even together with a HX711 for only 9€. On Amazon they cost about 13€ ?

Quality

At constant temperatures, these sensors work okay, but these cheap sensors show a so-called temperature drift. This means that the measurement result changes with increasing temperature. Therefore the better weight sensors are to be recommended.

In addition, the measured weight changes over time. If you only want to measure the relative honey yield in a short period of time, this can be sufficient. However, the absolute weight drifts off over a longer period of time.

Compensation of temperature-dependent deviations

The HoneyPi firmware has a so-called temperature compensation built in, so that the above mentioned deviations can be compensated by a calibration. Read about it here.

Wiring

Here are some graphics that actually all show the same thing: The wiring of the four half bridges weight sensors. The red cables at the load cells lead to the HX711 (A/D converter).

Wiring of the 4 half bridge load cells to the HX711.

4x Half Bridge load cells on HX711

  • Green A-
  • Grey A+
  • Black E-
  • Red E+

Translated 19.10.2019 by JK

Print Friendly, PDF & Email

24 thoughts on “4x Half Bridge load cells

  1. nosch

    Hallo Alf! Du liegst richtig! Gleiches habe ich auch festgestellt und die Fotos sind von mir – siehe Kommentare weiter unten.

    Reply
  2. Alf

    Hallo Javan

    Erstmal Danke, tolles Projekt!!
    Vielleicht irre ich mich, aber die Beschaltung der gezeichneten Versionen unterscheidet sich von dem Foto.
    Auf dem Foto sehe ich, daß der Eingang sowie der Ausgang jeweils an den Mittelpunkten von zwei diagonal liegenden Wägzellen angeschlossen ist. Auf den beiden Zeichnungen jedoch an zwei nebeneinander liegenden Zellen.

    Diagonal funktioniert bei mir, nebeneinander nicht.

    Vielen Dank fürs drauf schauen.

    Liebe Grüße

    Alf

    Reply
  3. nosch

    Wenn ich die Halbbrücken nach obigen Schema anschließe, funktioniert nichts. Nach dem Schema von Beelogger (https://beelogger.de/stockwaage/aufbauanleitung_mit_halbbrueckensensoren/) klappt es.

    Dort werden die Versorgungsspannung bzw. die Signalanschlüsse jeweils an den diagonal gegenüberliegenden Zellen angeschlossen und nicht an den nebeneinanderliegenden.

    Außerdem hatten wir Probleme mit den Schraubkontakten unseres HX711 Moduls. Durch Anlöten dickerer Kabelenden und Kürzen der Kabel sind die Messungen nun in Ordnung.

    Reply
    1. nosch

      HIer findet man einen schönen Anschlußplan mit der diagonalen Anschlussvariante:
      https://esp8266-server.de/waage.html
      In einem Forum hab ich gelesen, dass es von den Halbbrücken abhänge, wie sie angeschlossen erden müssen…? Kann hier jeman bitte aufklären?

      Reply
  4. Jörg

    Hallo zusammen,
    ich kämpfe gerade mit den Wägezellen (im Moment gewinnen sie noch 🙂
    Wenn ich am HX keine Zellen anschliessen, kommt ein Messergebnis beim PI an. Sobald ich die Zellen gemäß oberem Schema anschliesse, kriegt der PI keine Werte mehr =>
    2022-02-24 19:58:17,885 | WARNING | HoneyPi.read_hx711 | HX711 DT: 5 SCK: 6 Channel: A Initializing HX711 failed: mean requires at least one data point
    An E+/E- messe ich 2.68V an A+/A- 0,87V im unbelastetem Zustand….
    Jörg

    Reply
    1. Javan Post author

      Hi Jörg, die Meldung zeigt, dass dein HX711 oder die Wägezellen falsch angeschlossen sind.

      Reply
  5. Christian

    Hallo Leute, ich hätte da auch eine Frage, bezüglich der Halfe bridge sensoren. Ich habe mir zwei Vierkanthölzer gemacht, wo die Sensoren mittels einem 3 Druck halter montiert sind. Jetzt meine Frage, müssen die Kabel zwischen den Sensoren abgeschirmt sein, also sprich Netzwerkkabel. Ich habe nämlich total unterschiedliche Messergebnisse. Bitte um Infos. Vielen Dank

    Reply
  6. Matthias Lauß

    Hi Leute!
    Danke erstmal für das tolle Projekt!
    Ich habe leider Probleme beim kalibrieren der Waagen. Komischerweise bekomme ich irgendwelche Utopische Werte, das bedeutet…
    1. wenn ich die Kalibrierung starte bekomme ich jedes mal unterschiedliche Werte für den Offset und auch für die skalierung
    2. bei jeder messung bekomme ich unterschiedliche Werte, zB -50, dann wieder 4000
    Das interessante daran ist das ich da jeweils nichts ändere an dem Gewicht das die Zellen belastet.
    Ich verwende einen Pi 4
    Hat hier jemand eine idee an was das liegen könnte?
    Lg
    Matthias

    Reply
  7. Capo

    Hello,
    I’ve been trying to read weight with this 4 half bridge load cells, but I suffered some troubles. I hope someone could help me. I use the same wiring that’s shown in this page, with a Raspberry Pi Zero WH too, with the latest version uploaded from github. The HX711 is connected to 3.3V, there’s no resistance between gnd and E- and pin 15 is connected to Vcc. During latest tests, only taster, led and witty pi mini 3 are connected to Raspberry. I’m using channel A from HX711.

    After some tries, I figured while I was calibrating HX711 via maintenance mode that the difference between no weight reading and 20kg reading was too small. I can adjust offset without problem, but the scale I must is too small to reach those 20kg (between 0,001 and 0,0007). With that, the minimum error variation of decimals in the reading, after the calibration it supposes an error of several kg.

    Those who have used 4 half bridge load cells, have you suffered the same problem? How did you solved?

    Thanks

    Reply
  8. Stefan

    Hallo,

    ist es auch möglich auf diese Art 4 hochwertige Wägezellen zu verbauen ?
    Ich bin leider ein volkommener Elektrodepp…
    Ich stelle mir vor anstatt der half bridge Zellen einfach 4x die Bosche zu verbauen.
    Funktioniert das so oder habe ich da einen Denkfeheler/ eine massive Wissenslücke ?

    Viele Grüße
    Stefan

    Reply
  9. Hannes

    Wie kann ich denn die “Half Bridge Wägezellen” testen, habe die wie im Bild angeschlossen und liefern immer nur 0,001g oder so auch wenn ich Last auflege.
    Wenn ich die Zelle wieder ausbaue kann ich zwischen rot und weiß bzw. schwarz immer einen Widerstand von 1k messen aber es ändert sich kein Widerstand wenn ich draufdrücke (oder reagiert der so nicht)

    Reply
    1. Javan Post author

      Hey Hannes,
      wenn immer 1 Gramm gemessen wird, dann liegt ein Fehler in der Verkabelung vor. 1 Gramm wird nämlich auch gemessen, wenn gar keine Wägezelle angeschlossen ist.
      Prüfe nochmal, ob alles richtig miteinander verbunden ist.
      Ich hoffe ich konnte dir helfen. Viele Grüße

      Reply
      1. Hannes

        Bin mir bezüglich Anschluss nicht sicher da die Bilder oben meiner Ansicht verschiedene Verkabelungen zeigen.
        Buntes Bild Input bei zwei benachbarten Zellen.
        SW Bild mit Widerständen zeigt Input Diagonal bei nicht benachbarten Zellen.
        Was ist da richtig oder eh nicht relevant.

        Reply
        1. Javan Post author

          Ich habe das schwarz-weiß Bild aus dem Beitrag entfernt, weil es hier wohl mehr zu Verwirrung gesorgt hat.

          Reply
  10. Mathias

    Hallo
    Ich bin gerade am testen mit den billigen Half-bridge.
    Habe gesehen das man 1kilo ohm zwischen den einzelnen Kabeln zwischen fügt bei den billigen Half-bridge sensoren.
    Wie habt ihr das gelöst .Muss man das überhaupt machen .

    Gruss Mathias

    Reply
    1. Javan Post author

      Nein, da müssen keine Widerstände zwischen die Wägezellen. Die können einfach miteinander verdrahtet werden.

      Die Zeichnung in der du das gesehen ist zeigt eher, wie eine solche Zelle aufgebaut ist. Also das sind die Widerstände die sozusagen da drin verbaut sind. LG

      Reply
  11. Helmut Riethmeier

    Hallo Javan wie lange kann ich die Anschluß Leitungen machen, meine TBH hat vier Füße.
    Wie lange kann die Leitung von der HD7 zum Raspberry in Metern sein 2M,4G ???
    Vielen Dank Gruß Helmut

    Reply
    1. Jörg

      Hallo
      Habe eine meiner TBH auch verkabelt und die Leitungen verlängert. Ging ohne Probleme. Das Längste war glaub ich gute 1.8m. Den HX711 hab ich an einen von den vier Füßen gespaxt in einer Verteilerdose. Von da zum Pi hab ich ein Telefonkabel von ca. 8m.
      Ich schicke mal ein paar Bilder für die Galerie dann sieht man das besser.
      Gruß Jörg

      Reply
  12. Helmut Riethmeier

    Hallo Javan vielen Dank für deine Info, nun habe ich noch eine Frage, ich habe gelesen das die half bridge Wägezellen Zuleitung nur maximal 0,75m lang sein darf ,ist das richt, wie lang ist deine Verbindung.
    Und wie wäre das den HX711 mit den Wägezellen sehr kurz zu verbinden und dann den Ausgang der HX711 zum
    Raspberry dafür länger zu gestalten.
    einen schönen Sonntag wünscht Dir Helmut

    Reply
    1. Javan Post author

      Die Verbindung zwischen Raspberry und HX711 kannst du länger machen.
      Ja, die Verbindung zwischen den half bridge Wägezellen habe ich die original Kabeln gelassen und nicht verlängert.

      Reply
  13. Helmut Riethmeier

    Hallo Javan, wioe müssen die 4 half bridge Wägezellen mechanisch eingebaut werden.
    Ich habe versucht über Google etwas zu finden bis jetzt habe ich leider keinen Treffer.
    Dadurch wende ich mich an dich, vielen Dank für deine Bemühungen.

    Gruß Helmut

    Reply
    1. Magnus

      Hola Helmut,

      eine Möglichkeit ist, Du arbeitest mit Fräse oder ähnlichem. Der ‘Rahmen’ des Halbbrückensensors muss stabilen Kontakt zu einem Bauteil haben, der Pin zur anderen Seite muss Kontakt zum anderen Bauteil haben.

      Die andere, ideale Methode ist wohl diese Halterung auf thingiverse.com (https://www.thingiverse.com/thing:2624188), aber dafür braucht man halt noch einen 3D-Drucker.

      VG, Magnus

      Reply

Leave a Reply to Helmut Riethmeier Cancel reply

Your email address will not be published.